CVEvulnerability
CVE-2025-65107
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-11-21
- Last modified
- 2026-10-19
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-285, CWE-352
Description
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK.
Affected configurations
• langfuse langfuse (>= 2.95.0 < 2.95.12)
• langfuse langfuse (>= 3.17.0 < 3.131.0)
Related
References
- https://github.com/langfuse/langfuse/security/advisories/GHSA-w9pw-c549-5m6w Mitigation, Vendor Advisory