CVEvulnerability

CVE-2026-39999

7.0 HIGH Published 2026-06-19 Modified 2026-10-25 Official page ↗
Status
Analyzed
Published
2026-06-19
Last modified
2026-10-25
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.0 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-290

Description

Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.

Affected configurations

• apache apisix (>= 2.2 < 3.17.0)

Related

Weakness · CWE (1)

  • CWE-290 Authentication Bypass by Spoofing weakness

References