CVEvulnerability
CVE-2026-42354
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-08
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-290
Description
Sentry is an error tracking and performance monitoring tool. From version 21.12.0 to before version 26.4.1, a critical vulnerability was discovered in the SAML SSO implementation of Sentry. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. This issue has been patched in version 26.4.1.
Affected configurations
• sentry sentry (>= 21.12.0 < 26.4.1)
Related
Weakness · CWE (1)
- CWE-290 Authentication Bypass by Spoofing weakness
References
- https://github.com/getsentry/sentry/commit/0c67558ae7fe08738912d4c5233b53ead048da3b Patch
- https://github.com/getsentry/sentry/pull/113720 Issue Tracking, Patch
- https://github.com/getsentry/sentry/releases/tag/26.4.1 Product, Release Notes
- https://github.com/getsentry/sentry/security/advisories/GHSA-rcmw-7mc7-3rj7 Mitigation, Vendor Advisory