CVEvulnerability
CVE-2026-49231
2.3 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.3 LOW — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-290
Description
Authentication Bypass by Spoofing vulnerability in opa plugin.
An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin.
This could allow the attacker to assume higher privileges on the upstream service.
This issue affects Apache APISIX: from 3.5.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected configurations
• apache apisix (>= 3.5.0 < 3.17.0)
Related
Weakness · CWE (1)
- CWE-290 Authentication Bypass by Spoofing weakness
References
- https://lists.apache.org/thread/s1jd1vxm59p6ghx47xhmpjdk1cobo4hn Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/13 Third Party Advisory