CVEvulnerability
CVE-2026-49871
2.1 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-19
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.1 LOW — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.3 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations.
This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity.
Actions the victim takes upstream are then attributed to attackers identity.
This issue affects Apache APISIX: from 3.0.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Affected configurations
• apache apisix (>= 3.0.0 < 3.17.0)
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://lists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/14 Third Party Advisory