GitHub Advisoryadvisory · Packagist

GHSA-237r-r8m4-4q88 Guzzle OAuth Subscriber has insufficient nonce entropy

MEDIUM Published 2025-01-06 Modified 2026-07-15 Official page ↗
Aliases
CVE-2025-21617
Ecosystem
Packagist
Packages
guzzlehttp/oauth-subscriber
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-338
Reviewed
2025-01-06

Affected packages

• Packagist guzzlehttp/oauth-subscriber: < 0.8.1 → fixed in 0.8.1

Description

Impact Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source (https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192). This can leave servers vulnerable to replay attacks when TLS is not used. Patches Upgrade to version 0.8.1 or higher. Workarounds No. References Issue is similar to https://nvd.nist.gov/vuln/detail/CVE-2025-22376.

Related

Alias · CVE (1)

  • CVE-2025-21617 Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. vulnerability

Weakness · CWE (1)

  • CWE-338 Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) weakness

References