GitHub Advisoryadvisory · RubyGems

GHSA-24fg-p96v-hxh8 actionpack Cross-Site Request Forgery vulnerability

MEDIUM Published 2017-10-24 Modified 2023-05-26 Official page ↗
Aliases
CVE-2011-0447
Ecosystem
RubyGems
Packages
actionpack
Severity
Moderate
Weaknesses
CWE-352
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 2.1.0, < 2.3.11 → fixed in 2.3.11 • RubyGems actionpack: >= 3.0.0, < 3.0.4 → fixed in 3.0.4

Description

Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.

Related

Alias · CVE (1)

  • CVE-2011-0447 Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References