GitHub Advisoryadvisory · Maven
GHSA-2f89-66v2-9p53 Jenkins Email Extension Plugin Cross-Site Request Forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-32980
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:email-ext
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-05-17
Affected packages
• Maven org.jenkins-ci.plugins:email-ext: < 2.96.1 → fixed in 2.96.1
Description
Jenkins Email Extension Plugin 2.96 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.
This allows attackers to make another user stop watching an attacker-specified job.
Email Extension Plugin 2.96.1 requires POST requests for the affected HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2023-32980 A cross-site request forgery (CSRF) vulnerability in Jenkins Email Extension Plugin allows attackers to make another user stop watching an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness