GitHub Advisoryadvisory · NuGet

GHSA-2m69-gcr7-jv3q SQLitePCLRaw.lib.e_sqlite3 has a vulnerable dependency on SQLite

HIGH Published 2025-07-15 Modified 2026-06-18 Official page ↗
Aliases
CVE-2025-6965
Ecosystem
NuGet
Packages
SQLitePCLRaw.lib.e_sqlite3, SQLitePCLRaw.lib.e_sqlite3.android, SQLitePCLRaw.lib.e_sqlite3.ios
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-197
Reviewed
2026-06-18

Affected packages

• NuGet SQLitePCLRaw.lib.e_sqlite3: <= 2.1.11 (no fix yet) • NuGet SQLitePCLRaw.lib.e_sqlite3.android: <= 2.1.11 (no fix yet) • NuGet SQLitePCLRaw.lib.e_sqlite3.ios: <= 2.1.11 (no fix yet)

Description

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

Related

Alias · CVE (1)

  • CVE-2025-6965 There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns… vulnerability

Weakness · CWE (1)

  • CWE-197 Numeric Truncation Error weakness

References