GitHub Advisoryadvisory · Packagist
GHSA-2p6p-9rc9-62j9 Craft CMS has potential RCE when PHP `register_argc_argv` config setting is enabled
CRITICAL
Official page ↗
- Aliases
- CVE-2024-56145
- Ecosystem
- Packagist
- Packages
- craftcms/cms
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
- Weaknesses
- CWE-78, CWE-94
- Reviewed
- 2024-12-18
Affected packages
• Packagist craftcms/cms: >= 5.0.0-RC1, < 5.5.2 → fixed in 5.5.2
• Packagist craftcms/cms: >= 4.0.0-RC1, < 4.13.2 → fixed in 4.13.2
• Packagist craftcms/cms: >= 3.0.0, < 3.9.14 → fixed in 3.9.14
Description
Impact
You are affected if your php.ini configuration has `register_argc_argv` enabled.
Patches
Update to 3.9.14, 4.13.2, or 5.5.2.
Workarounds
If you can't upgrade yet, and `register_argc_argv` is enabled, you can disable it to mitigate the issue.
Related
Alias · CVE (1)
- CVE-2024-56145 Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. vulnerability
References
- https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9 web
- https://nvd.nist.gov/vuln/detail/CVE-2024-56145 advisory
- https://github.com/craftcms/cms/commit/82e893fb794d30563da296bca31379c0df0079b3 web
- https://github.com/Chocapikk/CVE-2024-56145 web
- https://github.com/craftcms/cms package
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-56145 web