GitHub Advisoryadvisory · Go
GHSA-2w5v-x29g-jw7j Hashicorp Nomad Incorrect Authorization vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2024-10975
- Ecosystem
- Go
- Packages
- github.com/hashicorp/nomad
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2024-11-07
Affected packages
• Go github.com/hashicorp/nomad: <= 1.9.1 (no fix yet)
Description
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
Related
Alias · CVE (1)
- CVE-2024-10975 Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-10975 advisory
- https://github.com/hashicorp/nomad/commit/30849c518e16647a4f698e5f5cc82bef2bf40e4d web
- https://discuss.hashicorp.com/t/hcsec-2024-27-nomad-vulnerable-to-cross-namespace-volume-creation-abusing-csi-write-permission web
- https://github.com/advisories/GHSA-2w5v-x29g-jw7j advisory
- https://github.com/hashicorp/nomad package