GitHub Advisoryadvisory · Maven
GHSA-2wf5-4mf7-vmh3 CSRF vulnerability in Jenkins Active Directory Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2303
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:active-directory
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-21
Affected packages
• Maven org.jenkins-ci.plugins:active-directory: < 2.20 → fixed in 2.20
Description
Jenkins Active Directory Plugin 2.19 and earlier does not require POST requests for multiple HTTP endpoints implementing connection and authentication tests, resulting in cross-site request forgery (CSRF) vulnerabilities.
This vulnerability allows attackers to perform connection tests, connecting to attacker-specified or previously configured Active Directory servers using attacker-specified credentials.
Active Directory Plugin 2.20 requires POST requests for the affected HTTP endpoints.
Related
Alias · CVE (1)
- CVE-2020-2303 A cross-site request forgery (CSRF) vulnerability in Jenkins Active Directory Plugin 2.19 and earlier allows attackers to perform… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2303 advisory
- https://github.com/jenkinsci/active-directory-plugin/commit/3558971237b80e71e913ead9e82a722e9d5576b8 web
- https://github.com/jenkinsci/active-directory-plugin package
- https://www.jenkins.io/security/advisory/2020-11-04/#SECURITY-2126 web
- http://www.openwall.com/lists/oss-security/2020/11/04/6 web