GitHub Advisoryadvisory · Maven
GHSA-2wwh-qgh8-w9xw Jenkins Build Failure Analyzer Plugin Cross-Site Request Forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-43502
- Ecosystem
- Maven
- Packages
- com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-09-21
Affected packages
• Maven com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer: < 2.4.2 → fixed in 2.4.2
Description
Jenkins Build Failure Analyzer Plugin 2.4.1 and earlier does not require POST requests for an HTTP endpoint, resulting in cross-site request forgery (CSRF) vulnerabilities.
This vulnerability allows attackers to delete Failure Causes.
Build Failure Analyzer Plugin 2.4.2 requires POST requests for the affected HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2023-43502 A cross-site request forgery (CSRF) vulnerability in Jenkins Build Failure Analyzer Plugin 2.4.1 and earlier allows attackers to delete… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness