GitHub Advisoryadvisory · Maven, PyPI

GHSA-329j-jfvr-rhr6 Apache Spark vulnerable to Improper Privilege Management

CRITICAL Published 2023-04-17 Modified 2024-10-15 Official page ↗
Aliases
CVE-2023-22946
Ecosystem
Maven, PyPI
Packages
org.apache.spark:spark-core_2.12, org.apache.spark:spark-core_2.13, pyspark
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-269
Reviewed
2023-04-21

Affected packages

• Maven org.apache.spark:spark-core_2.12: < 3.3.3 → fixed in 3.3.3 • Maven org.apache.spark:spark-core_2.13: < 3.3.3 → fixed in 3.3.3 • PyPI pyspark: < 3.3.2 → fixed in 3.3.2

Description

In Apache Spark versions prior to versions 3.4.0 and 3.3.3, applications using spark-submit can specify a `proxy-user` to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0, 3.3.3, or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.

Related

Alias · CVE (1)

  • CVE-2023-22946 In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References