GitHub Advisoryadvisory · Maven

GHSA-337m-mw94-2v6g Apache Commons Configuration: StackOverflowError for YAML input with cycles

MEDIUM Published 2026-05-14 Modified 2026-05-20 Official page ↗
Aliases
CVE-2026-45205
Ecosystem
Maven
Packages
org.apache.commons:commons-configuration2
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-674
Reviewed
2026-05-20

Affected packages

• Maven org.apache.commons:commons-configuration2: >= 2.2, < 2.15.0 → fixed in 2.15.0

Description

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-45205 Uncontrolled Recursion vulnerability in Apache Commons. vulnerability

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References