GitHub Advisoryadvisory · Go

GHSA-33mj-cw25-m34h RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser

CRITICAL Published 2026-09-17 Modified 2026-09-17 Official page ↗
Aliases
CVE-2026-77405
Ecosystem
Go
Packages
github.com/rabbitmq/amqp091-go
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N
Weaknesses
CWE-316, CWE-326
Reviewed
2026-09-17

Affected packages

• Go github.com/rabbitmq/amqp091-go: < 1.13.0 → fixed in 1.13.0

Description

Summary A structural security weakness exists in the AMQP client's TLS configuration generator (`tlsConfigFromURI`). When constructing a `*tls.Config` object from an `amqps://` connection URI, the library initializes the structure without explicitly defining the `MinVersion` field. While modern versions of the Go compiler toolchain (Go 1.18+) default the implicit minimum version to TLS 1.2, this security posture relies entirely on an implicit toolchain dependency. If the library is compiled using legacy Go toolchains (Go < 1.18), or if a future toolchain introduces fallback behavior, the client could silently negotiate obsolete and insecure TLS 1.0 or TLS 1.1 protocols during connection handshakes with a compromised or malicious AMQP broker. --- Vulnerability Details Mechanism The vulnerability lies in the lack of an explicit safety floor when assigning configurations inside the URI component: ```go // Example within uri.go's tlsConfigFromURI cfg := &tls.Config{ ServerName: host, // MinVersion is left completely unassigned (defaults to 0, or toolchain default) } ``` In the Go standard library (`crypto/tls`), leaving `MinVersion: 0` instructs the runtime to choose the toolchain's default minimum. Prior to Go 1.18, this default allowed negotiation down to TLS 1.0. Relying on implicit compiler configurations violates secure coding practices by decoupling the library's security posture from its source code, leaving applications vulnerable based solely on how they are built. Impact If a client application is built with a legacy compiler environment or a custom Go runtime, an attacker capable of executing a Man-in-the-Middle (MitM) attack can force the connection to downgrade to TLS 1.0 or 1.1. This exposes the AMQP protocol data stream to well-known cryptographic vulnerabilities (such as BEAST, POODLE, or SWEET32), allowing the attacker to decrypt or alter message payloads, connection parameters, and authentication credentials. --- Attack Vector An attacker performing a network-level downgrade attack can intercept a client connection built under a legacy toolchain: 1. Interception: A client application compiled on a legacy pipeline attempts to establish an encrypted connection to an AMQP broker. 2. Protocol Downgrade: The attacker intercepts the TLS Client Hello handshake and forces a downgrade negotiation to TLS 1.0. 3. Cryptographic Exploitation: Because `MinVersion` was never explicitly locked to `tls.VersionTLS12` by the library, the client accepts the weak cipher suites, allowing the attacker to monitor or manipulate the underlying AMQP session data.

Related

Alias · CVE (1)

  • CVE-2026-77405 RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. vulnerability

Weakness · CWE (2)

  • CWE-316 Cleartext Storage of Sensitive Information in Memory weakness
  • CWE-326 Inadequate Encryption Strength weakness

References