GitHub Advisoryadvisory · npm

GHSA-363h-vj6q-3cmj Rosetta-Flash JSONP Vulnerability in hapi

MEDIUM Published 2020-08-31 Modified 2021-09-23 Official page ↗
Aliases
CVE-2014-4671
Ecosystem
npm
Packages
hapi
Severity
Moderate
Weaknesses
CWE-352
Reviewed
2020-08-31

Affected packages

• npm hapi: < 6.1.0 → fixed in 6.1.0

Description

This description taken from the pull request provided by Patrick Kettner. Versions 6.1.0 and earlier of hapi are vulnerable to a rosetta-flash attack, which can be used by attackers to send data across domains and break the browser same-origin-policy. Recommendation • Update hapi to version 6.1.1 or later. Alternatively, a solution previously implemented by Google, Facebook, and Github is to prepend callbacks with an empty inline comment. This will cause the flash parser to break on invalid inputs and prevent the issue, and how the issue has been resolved internally in hapi.

Related

Alias · CVE (1)

  • CVE-2014-4671 Adobe Flash Player before 13.0.0.231 and 14.x before 14.0.0.145 on Windows and OS X and before 11.2.202.394 on Linux, Adobe AIR before… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References