GitHub Advisoryadvisory · Maven

GHSA-3cjf-fwcq-xh22 Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions

MEDIUM Published 2025-02-04 Modified 2025-02-18 Official page ↗
Aliases
CVE-2025-24860
Ecosystem
Maven
Packages
org.apache.cassandra:cassandra-all
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-863
Reviewed
2025-02-04

Affected packages

• Maven org.apache.cassandra:cassandra-all: >= 4.0-alpha1, < 4.0.16 → fixed in 4.0.16 • Maven org.apache.cassandra:cassandra-all: >= 4.1-alpha1, < 4.1.8 → fixed in 4.1.8 • Maven org.apache.cassandra:cassandra-all: >= 5.0-alpha1, < 5.0.3 → fixed in 5.0.3

Description

Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer. Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions. This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer. Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-24860 Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References