GitHub Advisoryadvisory · npm

GHSA-3rh3-wfr4-76mj Regular expression Denial of Service in multiple packages

MEDIUM Published 2021-04-06 Modified 2021-04-30 Official page ↗
Aliases
CVE-2021-21391
Ecosystem
npm
Packages
@ckeditor/ckeditor5-engine, @ckeditor/ckeditor5-font, @ckeditor/ckeditor5-image, @ckeditor/ckeditor5-list, @ckeditor/ckeditor5-markdown-gfm, @ckeditor/ckeditor5-media-embed, @ckeditor/ckeditor5-paste-from-office, @ckeditor/ckeditor5-widget
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2021-03-31

Affected packages

• npm @ckeditor/ckeditor5-engine: < 27.0.0 → fixed in 27.0.0 • npm @ckeditor/ckeditor5-font: < 27.0.0 → fixed in 27.0.0 • npm @ckeditor/ckeditor5-image: < 27.0.0 → fixed in 27.0.0 • npm @ckeditor/ckeditor5-list: < 27.0.0 → fixed in 27.0.0 • npm @ckeditor/ckeditor5-markdown-gfm: < 27.0.0 → fixed in 27.0.0 • npm @ckeditor/ckeditor5-media-embed: < 27.0.0 → fixed in 27.0.0 • npm @ckeditor/ckeditor5-paste-from-office: < 27.0.0 → fixed in 27.0.0 • npm @ckeditor/ckeditor5-widget: < 27.0.0 → fixed in 27.0.0

Description

Impact A regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. Patches The problem has been recognized and patched. The fix will be available in version 27.0.0. For more information Email us at [email protected] if you have any questions or comments about this advisory. Acknowledgements The CKEditor 5 team would like to thank Yeting Li for recognizing and reporting these vulnerabilities.

Related

Alias · CVE (1)

  • CVE-2021-21391 CKEditor 5 provides a WYSIWYG editing solution. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References