GitHub Advisoryadvisory · Maven
GHSA-3rj3-qp2j-4fj2 Cross-Site Request Forgery in Jenkins P4 Plugin
HIGH
Official page ↗
- Aliases
- CVE-2021-21655
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:p4
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2021-05-19
Affected packages
• Maven org.jenkins-ci.plugins:p4: < 1.11.5 → fixed in 1.11.5
Description
A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.
Jenkins P4 Plugin 1.11.5 requires POST requests for the affected HTTP endpoints.
Related
Alias · CVE (1)
- CVE-2021-21655 A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness