GitHub Advisoryadvisory · Maven
GHSA-3v9f-4vff-rx42 Jenkins Static Analysis Utilities Plugin is vulnerable to Cross-site request forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2019-10307
- Ecosystem
- Maven
- Packages
- org.jvnet.hudson.plugins:analysis-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2023-10-26
Affected packages
• Maven org.jvnet.hudson.plugins:analysis-core: < 1.96 → fixed in 1.96
Description
Jenkins analysis-core Plugin has the capability to allow other plugins to display trend graphs for their static analysis results. analysis-core Plugin provides the configuration form for the default settings of each graph.
The configuration form and form submission handler did not perform a permission check, allowing attackers with Job/Read access to change the per-job graph configuration defaults for all users.
Additionally, the form submission handler did not require POST requests, resulting in a cross-site request forgery vulnerability.
analysis-core Plugin now requires Job/Configure permission and POST requests to configure the per-job graph defaults for all users.
Related
Alias · CVE (1)
- CVE-2019-10307 A cross-site request forgery vulnerability in Jenkins Static Analysis Utilities Plugin 1.95 and earlier in the… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-10307 advisory
- https://github.com/jenkinsci/analysis-core-plugin/commit/3d7a0c7907d831c58541508b893dcea2039809c5 web
- https://jenkins.io/security/advisory/2019-04-30/#SECURITY-1100 web
- https://web.archive.org/web/20200227073756/http://www.securityfocus.com/bid/108159 web
- http://www.openwall.com/lists/oss-security/2019/04/30/5 web