GitHub Advisoryadvisory · Maven

GHSA-3vcp-r62v-xpvg Apache DolphinScheduler vulnerable to Alert Script Attack

HIGH Published 2025-09-09 Modified 2025-11-05 Official page ↗
Aliases
CVE-2024-43115
Ecosystem
Maven
Packages
org.apache.dolphinscheduler:dolphinscheduler
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2025-09-10

Affected packages

• Maven org.apache.dolphinscheduler:dolphinscheduler: < 3.2.2 → fixed in 3.2.2

Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2024-43115 Improper Input Validation vulnerability in Apache DolphinScheduler. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References