GitHub Advisoryadvisory · Maven
GHSA-3wmv-7php-rhg5 Jenkins Vulnerable to Cross-Site Request Forgery (CSRF) Attack
LOW
Official page ↗
- Aliases
- CVE-2015-5318
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- Weaknesses
- CWE-352
- Reviewed
- 2025-03-13
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 1.625.2 → fixed in 1.625.2
• Maven org.jenkins-ci.main:jenkins-core: >= 1.626, < 1.638 → fixed in 1.638
Description
Jenkins before 1.638 and LTS before 1.625.2 uses a publicly accessible salt to generate CSRF protection tokens, which makes it easier for remote attackers to bypass the CSRF protection mechanism via a brute force attack.
Related
Alias · CVE (1)
- CVE-2015-5318 Jenkins before 1.638 and LTS before 1.625.2 uses a publicly accessible salt to generate CSRF protection tokens, which makes it easier for… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5318 advisory
- https://github.com/jenkinsci/jenkins/commit/f53802bb82a25b295b6dfa3bf2a591a6c8552183 web
- https://access.redhat.com/errata/RHSA-2016:0070 web
- https://github.com/jenkinsci/jenkins package
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-11-11 web
- http://rhn.redhat.com/errata/RHSA-2016-0489.html web