GitHub Advisoryadvisory · Maven

GHSA-42mm-x828-56c7 CSRF vulnerability in Jenkins Configuration Slicing Plugin

HIGH Published 2022-05-24 Modified 2023-10-27 Official page ↗
Aliases
CVE-2021-21617
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:configurationslicing
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2022-12-13

Affected packages

• Maven org.jenkins-ci.plugins:configurationslicing: < 1.52 → fixed in 1.52

Description

Jenkins Configuration Slicing Plugin 1.51 and earlier does not require POST requests for the form submission endpoint reconfiguring slices, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to apply different slice configurations to attacker-specified jobs. Jenkins Configuration Slicing Plugin 1.52 requires POST requests for the affected HTTP endpoint.

Related

Alias · CVE (1)

  • CVE-2021-21617 A cross-site request forgery (CSRF) vulnerability in Jenkins Configuration Slicing Plugin 1.51 and earlier allows attackers to apply… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References