GitHub Advisoryadvisory · Packagist

GHSA-43r4-vm25-qm78 Moodle has multiple cross-site request forgery (CSRF) vulnerabilities in the Forum module

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-7838
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-352
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.5.9 → fixed in 2.5.9 • Packagist moodle/moodle: >= 2.6.0, < 2.6.6 → fixed in 2.6.6 • Packagist moodle/moodle: >= 2.7.0, < 2.7.3 → fixed in 2.7.3

Description

Multiple cross-site request forgery (CSRF) vulnerabilities in the Forum module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allow remote attackers to hijack the authentication of arbitrary users for requests that set a tracking preference within (1) mod/forum/deprecatedlib.php, (2) mod/forum/forum.js, (3) mod/forum/index.php, or (4) mod/forum/lib.php.

Related

Alias · CVE (1)

  • CVE-2014-7838 Multiple cross-site request forgery (CSRF) vulnerabilities in the Forum module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References