GitHub Advisoryadvisory · npm

GHSA-472h-9c5j-prrr Backstage: Inconsistent credential enforcement for overlapping proxy routes

MEDIUM Published 2026-10-07 Modified 2026-10-07 Official page ↗
Aliases
CVE-2026-106456
Ecosystem
npm
Packages
@backstage/plugin-proxy-backend
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-863
Reviewed
2026-10-07

Affected packages

• npm @backstage/plugin-proxy-backend: >= 0.5.0, < 0.6.18 → fixed in 0.6.18

Description

Impact An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. Exploitation requires this specific overlapping route configuration. The resulting confidentiality and integrity impact depends on the capabilities exposed by the nested upstream. Patches Upgrade `@backstage/plugin-proxy-backend` to version `0.6.18` or later. The fixed package is available in Backstage v1.55.0. Workarounds • Avoid nesting a credential-protected proxy path below a path configured with `dangerously-allow-unauthenticated`. • Apply the same credential requirement to overlapping proxy paths. • Restrict direct network access to the Backstage backend until the patched package is deployed.

Related

Alias · CVE (1)

  • CVE-2026-106456 Backstage is an open framework for building developer portals. vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References