GitHub Advisoryadvisory · Maven

GHSA-47r2-phr8-m8cp Apache Pulsar Broker Improper Authentication vulnerability

MEDIUM Published 2023-07-12 Modified 2023-07-20 Official page ↗
Aliases
CVE-2023-31007
Ecosystem
Maven
Packages
org.apache.pulsar:pulsar-broker
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-287
Reviewed
2023-07-12

Affected packages

• Maven org.apache.pulsar:pulsar-broker: >= 2.9.0, < 2.10.4 → fixed in 2.10.4 • Maven org.apache.pulsar:pulsar-broker: >= 2.11.0, < 2.11.1 → fixed in 2.11.1

Description

Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false. This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0. 2.9 Pulsar Broker users should upgrade to at least 2.9.5. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected. Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.

Related

Alias · CVE (1)

  • CVE-2023-31007 Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References