GitHub Advisoryadvisory · Packagist
GHSA-499r-g7pc-vmp9 Composer: Arbitrary file write outside vendor via malicious transitive package name
HIGH
Official page ↗
- Aliases
- CVE-2026-59948
- Ecosystem
- Packagist
- Packages
- composer/composer
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-22, CWE-787
- Reviewed
- 2026-07-20
Affected packages
• Packagist composer/composer: >= 2.3.0, < 2.10.2 → fixed in 2.10.2
• Packagist composer/composer: >= 1.0.0, < 2.2.29 → fixed in 2.2.29
Description
Summary
A maliciously crafted package, published on an untrusted third party repository other than Packagist.org or Private Packagist, can cause Composer to write files outside the `vendor/` directory and outside your project, with attacker-controlled content, during a normal `install` or `update` through using an invalid package name, which was not correctly validated by Composer.
This is an arbitrary file write that can be used to execute code outside the Composer project's context in which you expected the package code to execute (for example by writing shell startup files, SSH `authorized_keys`, or a cron entry). It is a supply-chain issue: it requires a malicious or compromised package to be present in the dependency graph, it is not otherwise remotely exploitable against a machine.
The fix makes Composer validate every package produced by dependency resolution before anything is written to `composer.lock` or installed, and abort with a security error if a package name is not a valid `vendor/package` name.
Am I affected?
You may be affected if you install packages from an untrusted third party repository, which does not sufficiently validate package names. Packagist.org and Private Packagist are safe, as they validate package names correctly.
Patched versions
Fixed in 2.2.29 and 2.10.2. Composer 1.x is also affected and you should move to a safe 2.x release.
Workarounds
Do not use untrusted package repositories. If you have to, mirror them through an internal repository like Private Packagist.
Related
Alias · CVE (1)
- CVE-2026-59948 Composer is a dependency Manager for the PHP language. vulnerability
References
- https://github.com/composer/composer/security/advisories/GHSA-499r-g7pc-vmp9 web
- https://nvd.nist.gov/vuln/detail/CVE-2026-59948 advisory
- https://github.com/composer/composer/commit/502c6c4f699802d9cf464728b3e8a95674f919a0 web
- https://github.com/composer/composer/commit/c50b1efd13ebd73f6dca19b31424c5a02bf93cc1 web
- https://github.com/composer/composer package
- https://github.com/composer/composer/releases/tag/2.10.2 web
- https://github.com/composer/composer/releases/tag/2.2.29 web