GitHub Advisoryadvisory · Maven
GHSA-4ffq-6g62-j4v4 Cross-Site Request Forgery in the Jenkins Claim plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21620
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:claim
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2021-05-07
Affected packages
• Maven org.jenkins-ci.plugins:claim: < 2.18.2 → fixed in 2.18.2
Description
Jenkins Claim Plugin 2.18.1 and earlier does not require POST requests for the form submission endpoint assigning claims, resulting in a cross-site request forgery (CSRF) vulnerability.
This vulnerability allows attackers to change claims.
Jenkins Claim Plugin 2.18.2 requires POST requests for the affected HTTP endpoint.
Related
Alias · CVE (1)
- CVE-2021-21620 A cross-site request forgery (CSRF) vulnerability in Jenkins Claim Plugin 2.18.1 and earlier allows attackers to change claims. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness