GitHub Advisoryadvisory · Maven

GHSA-4gfc-72gw-v385 Jenkins Nexus Platform Plugin Cross-Site Request Forgery vulnerability

HIGH Published 2023-12-13 Modified 2023-12-18 Official page ↗
Aliases
CVE-2023-50766
Ecosystem
Maven
Packages
org.sonatype.nexus.ci:nexus-jenkins-plugin
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-352
Reviewed
2023-12-18

Affected packages

• Maven org.sonatype.nexus.ci:nexus-jenkins-plugin: < 3.18.1-01 → fixed in 3.18.1-01

Description

Jenkins Nexus Platform Plugin 3.18.0-03 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to send an HTTP request to an attacker-specified URL and parse the response as XML. Additionally, the plugin does not configure its XML parser to prevent XML external entity (XXE) attacks, so attackers can have Jenkins parse a crafted XML response that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Nexus Platform Plugin 3.18.1-01 configures its XML parser to prevent XML external entity (XXE) attacks. Additionally, POST requests and Overall/Administer permission are required for the affected HTTP endpoints.

Related

Alias · CVE (1)

  • CVE-2023-50766 A cross-site request forgery (CSRF) vulnerability in Jenkins Nexus Platform Plugin 3.18.0-03 and earlier allows attackers to send an HTTP… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References