GitHub Advisoryadvisory · Maven

GHSA-4m8c-h7fr-gq5c Cloud Foundry vulnerable to Cross-Site Request Forgery

CRITICAL Published 2022-05-13 Modified 2024-02-29 Official page ↗
Aliases
CVE-2016-6637
Ecosystem
Maven
Packages
org.cloudfoundry.identity:cloudfoundry-identity-server
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-352
Reviewed
2024-02-29

Affected packages

• Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 2.0.0, < 2.7.4.7 → fixed in 2.7.4.7 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.0.0, < 3.3.0.5 → fixed in 3.3.0.5 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.4.0, < 3.4.4 → fixed in 3.4.4 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.5.0, < 3.7.0 → fixed in 3.7.0

Description

Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before 3.3.0.5, and 3.4.x before 3.4.4; UAA BOSH before 11.5 and 12.x before 12.5; Elastic Runtime before 1.6.40, 1.7.x before 1.7.21, and 1.8.x before 1.8.2; and Ops Manager 1.7.x before 1.7.13 and 1.8.x before 1.8.1 allow remote attackers to hijack the authentication of unspecified victims for requests that approve or deny a scope via a profile or authorize approval page.

Related

Alias · CVE (1)

  • CVE-2016-6637 Multiple cross-site request forgery (CSRF) vulnerabilities in Pivotal Cloud Foundry (PCF) before 242; UAA 2.x before 2.7.4.7, 3.x before… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References