GitHub Advisoryadvisory · npm

GHSA-4pcg-wr6c-h9cq fastify/websocket vulnerable to uncaught exception via crash on malformed packet

HIGH Published 2022-11-07 Modified 2022-11-07 Official page ↗
Aliases
CVE-2022-39386
Ecosystem
npm
Packages
@fastify/websocket, fastify-websocket
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-248
Reviewed
2022-11-07

Affected packages

• npm @fastify/websocket: >= 5.0.0, < 5.0.1 → fixed in 5.0.1 • npm @fastify/websocket: >= 6.0.0, < 7.1.1 → fixed in 7.1.1 • npm fastify-websocket: <= 4.3.0 (no fix yet)

Description

Impact Any application using @fastify/websocket could crash if a specific, malformed packet is sent. All versions of fastify-websocket are also impacted. That module is deprecated, so it will not be patched. Patches This has been patched in v7.1.1 (fastify v4) and v5.0.1 (fastify v3). Workarounds No known workaround is available. However, it should be possible to attach the error handler manually. The recommended path is upgrading to the patched versions. Credits marcolanaro for finding and patching this vulnerability For more information If you have any questions or comments about this advisory: • Open an issue in @fastify/websocket • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2022-39386 @fastify/websocket provides WebSocket support for Fastify. vulnerability

Weakness · CWE (1)

  • CWE-248 Uncaught Exception weakness

References