GitHub Advisoryadvisory · PyPI

GHSA-538v-3wq9-4h3r Apache Pyfory python is vulnerable to deserialization of untrusted data

CRITICAL Published 2025-10-01 Modified 2025-11-05 Official page ↗
Aliases
CVE-2025-61622
Ecosystem
PyPI
Packages
pyfory, pyfury
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2025-10-01

Affected packages

• PyPI pyfory: >= 0.12.0, < 0.12.3 → fixed in 0.12.3 • PyPI pyfury: >= 0.1.0, <= 0.10.3 (no fix yet)

Description

Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.

Related

Alias · CVE (1)

  • CVE-2025-61622 Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References