GitHub Advisoryadvisory · Packagist
GHSA-5777-jj7p-mpqw Magento Cross-Site Request Forgery (CSRF) vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-49555
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2025-10-22
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: >= 2.4.9-alpha1, < 2.4.9-alpha2 → fixed in 2.4.9-alpha2
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-p2 → fixed in 2.4.8-p2
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p7 → fixed in 2.4.7-p7
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p12 → fixed in 2.4.6-p12
• Packagist magento/community-edition: < 2.4.5-p14 → fixed in 2.4.5-p14
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.8 (no fix yet)
Description
Magento versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a Cross-Site Request Forgery (CSRF) vulnerability that could result in privilege escalation. A high-privileged attacker could trick a victim into executing unintended actions on a web application where the victim is authenticated, potentially allowing unauthorized access or modification of sensitive data. Exploitation of this issue requires user interaction in that a victim must visit a malicious website or click on a crafted link. Scope is changed.
Related
Alias · CVE (1)
- CVE-2025-49555 Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a Cross-Site Request… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness