GitHub Advisoryadvisory · Packagist
GHSA-5834-xv5q-cgfw Shopware vulnerable to persistent cross site scripting (XSS) in customer module
MEDIUM
Official page ↗
- Aliases
- CVE-2022-31148
- Ecosystem
- Packagist
- Packages
- shopware/shopware
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-07-27
Affected packages
• Packagist shopware/shopware: >= 5.7.0, < 5.7.14 → fixed in 5.7.14
Description
Impact
Persistent XSS in customer module
Patches
We recommend updating to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview.
For older versions you can use the Security Plugin:
https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022
Related
Alias · CVE (1)
- CVE-2022-31148 Shopware is an open source e-commerce software. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/shopware/shopware/security/advisories/GHSA-5834-xv5q-cgfw web
- https://nvd.nist.gov/vuln/detail/CVE-2022-31148 advisory
- https://github.com/shopware/shopware/commit/7875855005648fba7b39371a70816afae2e07daf web
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-07-2022 web
- https://github.com/shopware/shopware package
- https://www.shopware.com/en/changelog-sw5/#5-7-14 web