GitHub Advisoryadvisory · Maven

GHSA-58jx-f5rf-qgqf User account escalation in Apache Hadoop

HIGH Published 2022-06-16 Modified 2022-06-24 Official page ↗
Aliases
CVE-2021-33036
Ecosystem
Maven
Packages
org.apache.hadoop:hadoop-yarn-server-common
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-22, CWE-502
Reviewed
2022-06-17

Affected packages

• Maven org.apache.hadoop:hadoop-yarn-server-common: >= 2.2.0, < 2.10.2 → fixed in 2.10.2 • Maven org.apache.hadoop:hadoop-yarn-server-common: >= 3.0.0, < 3.2.3 → fixed in 3.2.3 • Maven org.apache.hadoop:hadoop-yarn-server-common: >= 3.3.0, < 3.3.2 → fixed in 3.3.2

Description

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Related

Alias · CVE (1)

  • CVE-2021-33036 In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can… vulnerability

Weakness · CWE (2)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References