GitHub Advisoryadvisory · RubyGems
GHSA-58r4-h6v8-jcvm Regression in JWT Signature Validation
HIGH
Official page ↗
- Aliases
- CVE-2020-15240
- Ecosystem
- RubyGems
- Packages
- omniauth-auth0
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-287, CWE-347
- Reviewed
- 2020-10-27
Affected packages
• RubyGems omniauth-auth0: >= 2.3.0, < 2.4.1 → fixed in 2.4.1
Description
Overview
Versions after and including `2.3.0` are improperly validating the JWT token signature when using the `JWTValidator.verify` method. Improper validation of the JWT token signature when not using the default Authorization Code Flow can allow an attacker to bypass authentication and authorization.
Am I affected?
You are affected by this vulnerability if all of the following conditions apply:
• You are using `omniauth-auth0`.
• You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow.
How to fix that?
Upgrade to version `2.4.1`.
Will this update impact my users?
The fix provided in this version will not affect your users.
Related
Alias · CVE (1)
- CVE-2020-15240 omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify`… vulnerability
References
- https://github.com/auth0/omniauth-auth0/security/advisories/GHSA-58r4-h6v8-jcvm web
- https://nvd.nist.gov/vuln/detail/CVE-2020-15240 advisory
- https://github.com/auth0/omniauth-auth0/commit/fd3a14f4ccdfbc515d1121d6378ff88bf55a7a7a web
- https://github.com/auth0/omniauth-auth0 package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-auth0/CVE-2020-15240.yml web
- https://rubygems.org/gems/omniauth-auth0 web