GitHub Advisoryadvisory · Maven
GHSA-5cxw-8v65-76vf CSRF vulnerability in Jenkins promoted builds Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21641
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:promoted-builds
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-13
Affected packages
• Maven org.jenkins-ci.plugins:promoted-builds: < 3.9.1 → fixed in 3.9.1
Description
Jenkins promoted builds Plugin 3.9 and earlier does not require POST requests for HTTP endpoints implementing promotion (regular, forced, and re-execute), resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to promote builds.
Jenkins promoted builds Plugin 3.9.1 requires POST requests for the affected HTTP endpoints.
A security hardening since Jenkins 2.287 and LTS 2.277.2 prevents exploitation of this vulnerability.
Related
Alias · CVE (1)
- CVE-2021-21641 A cross-site request forgery (CSRF) vulnerability in Jenkins promoted builds Plugin 3.9 and earlier allows attackers to to promote builds. vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21641 advisory
- https://github.com/jenkinsci/promoted-builds-plugin/commit/46086a74891d620042c3d28a19cba3510c5dbf6a web
- https://github.com/jenkinsci/promoted-builds-plugin package
- https://www.jenkins.io/security/advisory/2021-04-07/#SECURITY-2293 web
- http://www.openwall.com/lists/oss-security/2021/04/07/2 web