GitHub Advisoryadvisory · PyPI

GHSA-5f35-pq34-c87q Apache Airflow missing Certificate Validation

MEDIUM Published 2023-08-23 Modified 2024-03-06 Official page ↗
Aliases
CVE-2023-39441
Ecosystem
PyPI
Packages
apache-airflow-providers-smtp, apache-airflow-providers-imap, apache-airflow
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-295
Reviewed
2023-08-24

Affected packages

• PyPI apache-airflow-providers-smtp: < 1.3.0 → fixed in 1.3.0 • PyPI apache-airflow-providers-imap: < 3.3.0 → fixed in 3.3.0 • PyPI apache-airflow: < 2.7.0 → fixed in 2.7.0

Description

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

Related

Alias · CVE (1)

  • CVE-2023-39441 Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the… vulnerability

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References