GitHub Advisoryadvisory · Maven
GHSA-5frh-wx6v-8m2r CSRF vulnerabilities in Jenkins requests-plugin Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21675
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:requests
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-16
Affected packages
• Maven org.jenkins-ci.plugins:requests: < 2.2.13 → fixed in 2.2.13
Description
Jenkins requests-plugin Plugin 2.2.12 and earlier does not require POST requests to request and apply changes, resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to create requests and/or have administrators apply pending requests, like renaming or deleting jobs, deleting builds, etc.
Jenkins requests-plugin Plugin 2.2.13 requires POST requests for the affected HTTP endpoints. This was partially fixed in requests-plugin Plugin 2.2.8 to require POST requests for some of the affected HTTP endpoints, but the endpoint allowing administrators to apply pending requests remained unprotected until 2.2.13.
Related
Alias · CVE (1)
- CVE-2021-21675 A cross-site request forgery (CSRF) vulnerability in Jenkins requests-plugin Plugin 2.2.12 and earlier allows attackers to create requests… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness