GitHub Advisoryadvisory · Maven
GHSA-5gwq-4275-q4qc Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials
HIGH
Official page ↗
- Aliases
- CVE-2018-1000401
- Ecosystem
- Maven
- Packages
- com.amazonaws:aws-codepipeline
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-522
- Reviewed
- 2022-11-08
Affected packages
• Maven com.amazonaws:aws-codepipeline: < 0.37 → fixed in 0.37
Description
Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.
Related
Alias · CVE (1)
- CVE-2018-1000401 Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness