GitHub Advisoryadvisory · npm

GHSA-5gwx-wf9g-r5mx NodeBB vulnerable to Cross-Site Request Forgery

MEDIUM Published 2022-11-13 Modified 2022-11-19 Official page ↗
Aliases
CVE-2022-3978
Ecosystem
npm
Packages
nodebb
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-352
Reviewed
2022-11-16

Affected packages

• npm nodebb: < 2.5.8 → fixed in 2.5.8

Description

A vulnerability was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component.

Related

Alias · CVE (1)

  • CVE-2022-3978 A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References