GitHub Advisoryadvisory · PyPI

GHSA-5j2h-h5hg-3wf8 Cross-site request forgery in Django

HIGH Published 2018-07-23 Modified 2026-05-19 Official page ↗
Aliases
CVE-2011-0696
Ecosystem
PyPI
Packages
Django
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-352
Reviewed
2020-06-16

Affected packages

• PyPI Django: >= 1.1, < 1.1.4 → fixed in 1.1.4 • PyPI Django: >= 1.2, < 1.2.5 → fixed in 1.2.5

Description

Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged AJAX requests that leverage a "combination of browser plugins and redirects," a related issue to CVE-2011-0447.

Related

Alias · CVE (1)

  • CVE-2011-0696 Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 does not properly validate HTTP requests that contain an X-Requested-With header, which… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References