GitHub Advisoryadvisory · Packagist

GHSA-5jph-mvfm-r27p Moodle cross-site request forgery (CSRF) vulnerability

MEDIUM Published 2022-05-13 Modified 2024-01-29 Official page ↗
Aliases
CVE-2015-0218
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-352
Reviewed
2024-01-29

Affected packages

• Packagist moodle/moodle: < 2.6.7 → fixed in 2.6.7 • Packagist moodle/moodle: >= 2.7.0, < 2.7.4 → fixed in 2.7.4 • Packagist moodle/moodle: >= 2.8.0, < 2.8.2 → fixed in 2.8.2

Description

Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.

Related

Alias · CVE (1)

  • CVE-2015-0218 Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before… vulnerability

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References