GitHub Advisoryadvisory · Maven

GHSA-5m5f-qg8r-p9qf OpenNMS vulnerable to remote code execution

HIGH Published 2023-08-17 Modified 2023-08-18 Official page ↗
Aliases
CVE-2023-40313
Ecosystem
Maven
Packages
org.opennms:opennms-base-assembly
Severity
High
CVSS vector
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
Weaknesses
CWE-94
Reviewed
2023-08-18

Affected packages

• Maven org.opennms:opennms-base-assembly: < 32.0.2 → fixed in 32.0.2

Description

A BeanShell interpreter in remote server mode runs in OpenNMS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Related

Alias · CVE (1)

  • CVE-2023-40313 A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References