GitHub Advisoryadvisory · Packagist

GHSA-5w2h-59j3-8x5w TYPO3 Install Tool vulnerable to Code Execution

HIGH Published 2024-02-13 Modified 2025-09-15 Official page ↗
Aliases
CVE-2024-22188
Ecosystem
Packagist
Packages
typo3/cms-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77, CWE-94
Reviewed
2024-02-13

Affected packages

• Packagist typo3/cms-core: >= 8.0.0, < 8.7.57 → fixed in 8.7.57 • Packagist typo3/cms-core: >= 9.0.0, < 9.5.46 → fixed in 9.5.46 • Packagist typo3/cms-core: >= 10.0.0, < 10.4.43 → fixed in 10.4.43 • Packagist typo3/cms-core: >= 11.0.0, < 11.5.35 → fixed in 11.5.35 • Packagist typo3/cms-core: >= 12.0.0, < 12.4.11 → fixed in 12.4.11 • Packagist typo3/cms-core: >= 13.0.0, < 13.0.1 → fixed in 13.0.1

Description

Problem Several settings in the Install Tool for configuring the path to system binaries were vulnerable to code execution. Exploiting this vulnerability requires an administrator-level backend user account with system maintainer permissions. The corresponding change for this advisory involves enforcing the known disadvantages described in TYPO3-PSA-2020-002: Protecting Install Tool with Sudo Mode. Solution Update to TYPO3 versions 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, 13.0.1 that fix the problem described. Credits Thanks to Rickmer Frier & Daniel Jonka who reported this issue and to TYPO3 core & security team member Benjamin Franzke who fixed the issue. References • TYPO3-CORE-SA-2024-002

Related

Alias · CVE (1)

  • CVE-2024-22188 TYPO3 before 13.0.1 allows an authenticated admin user (with system maintainer privileges) to execute arbitrary shell commands (with the… vulnerability

Weakness · CWE (2)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness
  • CWE-94 Improper Control of Generation of Code weakness

References