GitHub Advisoryadvisory · Maven
GHSA-5x9h-93gp-chpj Apache Wicket has a Cross-site Scripting issue
MEDIUM
Official page ↗
- Aliases
- CVE-2026-42509
- Ecosystem
- Maven
- Packages
- org.apache.wicket:wicket-parent
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2026-05-11
Affected packages
• Maven org.apache.wicket:wicket-parent: >= 8.0.0-M1, <= 8.17.0 (no fix yet)
• Maven org.apache.wicket:wicket-parent: >= 9.0.0-M1, <= 9.22.0 (no fix yet)
• Maven org.apache.wicket:wicket-parent: >= 10.0.0-M1, < 10.9.0 → fixed in 10.9.0
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Related
Alias · CVE (1)
- CVE-2026-42509 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness