GitHub Advisoryadvisory · Maven
GHSA-62fp-j75q-mqhc Jenkins CRX Content Package Deployer Plugin subject to Cross-Site Request Forgery
HIGH
Official page ↗
- Aliases
- CVE-2019-10437
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:crx-content-package-deployer
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
- Reviewed
- 2022-12-06
Affected packages
• Maven org.jenkins-ci.plugins:crx-content-package-deployer: < 1.9 → fixed in 1.9
Description
A cross-site request forgery vulnerability in Jenkins CRX Content Package Deployer Plugin prior to 1.9 allowed attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. This issue is patched in version 1.9
Related
Alias · CVE (1)
- CVE-2019-10437 A cross-site request forgery vulnerability in Jenkins CRX Content Package Deployer Plugin 1.8.1 and earlier allowed attackers to connect to… vulnerability
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-10437 advisory
- https://github.com/jenkinsci/crx-content-package-deployer-plugin/commit/1313c422170a064dab0f9359324ff27e30a9f4a5 web
- https://github.com/jenkinsci/crx-content-package-deployer-plugin web
- https://jenkins.io/security/advisory/2019-10-16/#SECURITY-1006%20(1) web