GitHub Advisoryadvisory · RubyGems
GHSA-639h-86hw-qcjq Decidim has broken access control in templates
HIGH
Official page ↗
- Aliases
- CVE-2023-36465
- Ecosystem
- RubyGems
- Packages
- decidim, decidim-templates
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
- Weaknesses
- CWE-284, CWE-732
- Reviewed
- 2023-10-05
Affected packages
• RubyGems decidim: >= 0.23.2, < 0.26.8 → fixed in 0.26.8
• RubyGems decidim-templates: >= 0.23.2, < 0.26.8 → fixed in 0.26.8
• RubyGems decidim-templates: >= 0.27.0, < 0.27.4 → fixed in 0.27.4
• RubyGems decidim: >= 0.27.0, < 0.27.4 → fixed in 0.27.4
Description
Impact
The `templates` module doesn't enforce the correct permissions, allowing any logged-in user to access to this functionality in the administration panel. An attacker could use this vulnerability to change, create or delete templates of surveys.
Related
Alias · CVE (1)
- CVE-2023-36465 Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and… vulnerability
References
- https://github.com/decidim/decidim/security/advisories/GHSA-639h-86hw-qcjq web
- https://nvd.nist.gov/vuln/detail/CVE-2023-36465 advisory
- https://github.com/decidim/decidim package
- https://github.com/decidim/decidim/releases/tag/v0.26.8 web
- https://github.com/decidim/decidim/releases/tag/v0.27.4 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-templates/CVE-2023-36465.yml web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2023-36465.yml web