GitHub Advisoryadvisory · Packagist
GHSA-67c6-q4j4-hccg Flarum vulnerable to LFI and Blind SSRF via Avatar upload
HIGH
Official page ↗
- Aliases
- CVE-2023-40033
- Ecosystem
- Packagist
- Packages
- flarum/core, flarum/framework
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-918, CWE-98
- Reviewed
- 2023-08-16
Affected packages
• Packagist flarum/core: < 1.8.0 → fixed in 1.8.0
• Packagist flarum/framework: < 1.8.0 → fixed in 1.8.0
Description
Impact
The Flarum forum software is affected by a vulnerability that allows an attacker to conduct a Blind SSRF attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack.
Patches
This has been patched in Flarum v1.8.
Workarounds
As a temporary workaround for the SSRF aspect of the vulnerability, one can disable PHP's `allow_url_fopen` which will prevent the fetching of external files via URLs.
Credits
Adam Kues - Assetnote
Related
Alias · CVE (1)
- CVE-2023-40033 Flarum is an open source forum software. vulnerability